Japanese Instance: Degraded performance on certain actions in PMS-studies
Incident Report for Viedoc
Postmortem

For the Japanese Viedoc instance, degraded performance was reported for specific tasks in the PMS studies. Non-PMS studies were not affected. These included actions such as: - opening subject cards - clicking “manage” for partially submitted forms - saving forms - booklet actions submit, return, and recall.

Issues were identified and performance was improved in Viedoc 4.77.

With the release of 4.77 on 2023-10-06 this issue was resolved. Performance was immediately restored as expected.

Posted Apr 08, 2024 - 09:48 UTC

Resolved
Viedoc 4.77 has now been released on the Japanese training and production instances. Several fixes for PMS-studies are included, resulting in a significant improved performance.
Posted Oct 06, 2023 - 10:14 UTC
Update
The release of Viedoc 4.77 has been postponed and is now planned release 5th (JP), 9th (EU) and 10th (CN) of October. The rationale for releasing 4.77 in Japan first is that the release is including some prioritized performance improvements in Japanese PMS studies.
Posted Oct 02, 2023 - 15:54 UTC
Update
The release of Viedoc 4.77 has been postponed one week and is now planned for release the 3rd - 5th of October.
Posted Sep 22, 2023 - 08:29 UTC
Update
The release of Viedoc 4.77 has been postponed one week and is now planned for release 26th - 28st of September.
Posted Sep 11, 2023 - 12:08 UTC
Update
Issues have been identified in the remaining categories ("opening subject cards", "saving forms" and "booklet actions submit, return, and recall"). Performance improvements are currently being implemented. The current plan is to release these improvements in the upcoming release 4.77 (currently planned for 19th - 21st of September)
Posted Aug 30, 2023 - 14:45 UTC
Identified
Issues related to "clicking “manage” for partially submitted forms" have been identified and work is ongoing for fixing those issues. Other actions with degraded performance are still being investigated.
Posted Aug 27, 2023 - 19:21 UTC
Investigating
For the Japanese Viedoc instance in PMS studies there are some actions that currently have degraded performance. These include actions such as:
- opening subject cards
- clicking “manage” for partially submitted forms
- saving forms
- booklet actions submit, return, and recall.
Investigations are ongoing to identify the problems to be able to improve the performance of these actions. Progress of our investigations will be updated on this page.

These performance issues are not present in non-PMS studies or other instances.
Posted Aug 22, 2023 - 12:27 UTC
This incident affected: Viedoc 4 - Japan (Main portal (clinic/admin/designer)).