Problem launching Viedoc on the European production instance

Incident Report for Viedoc

Postmortem

Description                                                                               

STS failure, impacting user login services.

Instances affected

Viedoc 4 Production Instance, Europe.

Duration

2025-01-16 11:46 UTC to 2025-01-16 11:57 UTC.

Cause

2025-01-16 11.46 UTC – Alerts were received from the automated platform monitoring, saying that the STS (security token service), managing authentication of users, unexpectedly stopped due to exceeding its operating capacity.

Impact

The issue led to Viedoc users on the European production instance being unable to access the login page and login to the system. There was no impact to other instances.

Corrective action

The STS was restarted and at 2025-01-16 11.57 UTC the users could access the European production instance as expected again.

Preventive action

Investigation is ongoing to determine the cause of the exception and how to prevent this from happening in the future.

Posted Jan 23, 2025 - 11:44 UTC

Resolved

The incident has been resolved since 11.57 UTC. Users can since then launch Viedoc as expected again.
Posted Jan 16, 2025 - 11:59 UTC

Update

We are continuing to investigate this issue.
Posted Jan 16, 2025 - 11:56 UTC

Investigating

Operational disturbance observed in the Viedoc application on the European instance (v4.viedoc.net). Users are currently unable to access the login page and a "runtime error" is displayed to the user.

Investigations are ongoing.
Posted Jan 16, 2025 - 11:52 UTC
This incident affected: Viedoc 4 - Europe (Main portal (clinic/admin/designer), Subject portal (ViedocMe), Application programming interface (API), Background processes (import/export/revisions/alerts/archive/disposal), Reporting tool (ViedocReports), Document management (ViedocTMF)).