Text messages occasionally not delivered for US phone numbers (+1 country code)
Incident Report for Viedoc
Postmortem

Viedoc service issue report

Report author
Ted Lähteenmäki, Manager IT Operations
Viedoc Technologies AB
Phone: +46 736 92 26 12
Email: ted.lahteenmaki@viedoc.com

Report issued
2022-12-05

Description
Text messages (SMS) occasionally not delivered for US phone numbers (+1 country code)

Instances affected
Viedoc 4 - Europe Main portal (clinic/admin/designer), Subject portal (ViedocMe).
There were no known interruptions in the service of SMS in other regions.

Duration
2022-11-29 17:00 UTC - 2022-11-30 17:40 UTC

Cause
Primary SMS service provider had an interruption on the SMS service causing SMS with country prefix +1 to be sent with secondary provider. The secondary provider had intermittent delivery issues to some +1 numbers.

 Corrective action
The primary SMS service provider corrected their issue.

Preventive action
Viedoc has followed up with the secondary provider to make sure that they review the problems with intermittent delivery issues for the SMS to numbers with country prefix +1, US.

Posted Dec 06, 2022 - 08:24 UTC

Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 17:42 UTC
Investigating
Text messages sent to US are occasionally failing due to an issue at our primary provider. When the service for the primary provider is failing, the secondary provider is called in to action. Most text messages are then being delivered as expected, but messages are occasionally failing with the secondary provider. The issue has been ongoing since 2022-11-29 at 18:00 CET.

Troubleshooting is ongoing at the vendor side.

There are no known interruptions in the service of text messages in other regions.
Posted Nov 30, 2022 - 17:27 UTC
This incident affected: Viedoc 4 - Europe (Main portal (clinic/admin/designer), Subject portal (ViedocMe)).