Viedoc Version on Viedoc 4 Training (France) temporarily rolled back to Viedoc 4.71
Incident Report for Viedoc
Postmortem

Viedoc service issue report

Report author

Ted Lähteenmäki Manager IT-Operations
Viedoc Technologies AB
Phone: +46 (0) 736 92 26 12
Email: Ted.lahteenmaki@viedoc.com

Report issued
2022-10-24

Description
Viedoc Version on Viedoc 4 Training (France) temporarily rolled back to Viedoc 4.71.

Instances affected
Viedoc 4 on Training instance France.

Duration
2022-10-18 11:30 - 2022-10-19 17:15 UTC+2

Cause
Viedoc 4.72 was released on the training server of the European instance 2022-10-18. This version introduced a bug.

Impact
Design validation in specific cases returned incorrect errors preventing the users from publishing the design.

Data integrity and data confidentiality not affected.

Corrective action

The version was rolled back to Viedoc 4.71 on Viedoc 4 Training (France).

Preventive action

The bug causing the problem has been fixed in the new release.

 New release date for Viedoc 4.72

Planned for 2022-11-01 (Europe servers)

Planned for 2022-11-02 (Japan servers)

Planned for 2022-11-03 (China servers)

Posted Oct 24, 2022 - 14:54 UTC

Resolved
This incident has been resolved.
Posted Oct 20, 2022 - 07:11 UTC
Investigating
Viedoc 4.72 was released on the training server of the European instance 2022-10-18. This version introduced a bug, leading the design validation in specific cases to return incorrect errors preventing the users to publish the design. As an immediate action, the version has been rolled back to Viedoc 4.71 on the European training server. As a consequence, the login page has now been reverted to the old version. This issue is isolated to the training server of the European instance.

Work is in progress to correct the issue, before Viedoc 4.72 is released on all instances.
Posted Oct 20, 2022 - 07:10 UTC
This incident affected: Viedoc 4 - Europe (Main portal (clinic/admin/designer), Background processes (import/export/revisions/alerts/archive/disposal)).