Problem accessing Viedoc instances
Incident Report for Viedoc
Postmortem

Viedoc service issue report

Report author

Claes Aspman, Manager Quality Assurance

Viedoc Technologies AB
Phone: +46 (0)736 56 11 00
Email: claes.aspman@viedoc.com

Report issued

2021-03-11

Description

We experienced a DNS failure due to our DNS service provider having an outage. Dependent on DNS record propagation, customers may have experienced problems accessing Viedoc instances.

Instances affected

All Viedoc instances served out of Europe and Japan.

Duration

2021-03-10 23:48 UTC – 2021-03-11 00:36 UTC

Cause

The issue was caused by an incident at our DNS service provider, Oracle Dyn.

Corrective action

Oracle Dyn restored the DNS service.

Oracle Dyn incident report is available at https://www.dynstatus.com/incidents/x8psymmjc5bw

Preventive action

We will assess the continued use of our current DNS service provider and look into improving redundancy.

Posted Mar 11, 2021 - 10:28 UTC

Resolved
We experienced a major issue with our DNS provider, the issue has now been resolved.
Posted Mar 11, 2021 - 00:46 UTC
Investigating
We are currently investigating this issue.
Posted Mar 11, 2021 - 00:25 UTC
This incident affected: Viedoc 4 - Europe (Main portal (clinic/admin/designer), Subject portal (ViedocMe), Application programming interface (API), Background processes (import/export/revisions/alerts/archive/disposal)), Viedoc 4 - Japan (Main portal (clinic/admin/designer), Subject portal (ViedocMe), Application programming interface (API), Background processes (import/export/revisions/alerts/archive/disposal)), and Viedoc 3 - Japan, Viedoc 3 - Europe.