Operational disturbance observed on the European instance

Incident Report for Viedoc

Postmortem

Viedoc service issue report

Report author

Ted Lähteenmäki, Manager IT Operations
Viedoc Technologies AB 
Email: ted.lahteenmaki@viedoc.com 

Report issued
2025-03-07

Description
Temporary unavailability of Reports application.

Instances affected
Viedoc 4 Production Instance, Europe.

Duration
2025-03-03 15:10 UTC to 2025-03-03 16:05 UTC.

Incident time stamps on the Viedoc Status Page have been updated to reflect actual start and resolution time after analyzing all log entries related to this incident.

Cause
2025-03-03 15:10 UTC – Reports application experienced an unexpected restart.
This incident was identified as being caused by human error while performing maintenance work.

Impact
Availability only. Data integrity and data confidentiality not affected.

Corrective action
Viedoc Reports dependent resources were restarted and the Viedoc Reports application was available again at 2025-03-03 16:05 UTC.

Preventive action

The routines for maintenance work will be scrutinized to avoid human errors.

Posted Mar 07, 2025 - 07:32 UTC

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 16:05 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2025 - 15:40 UTC

Investigating

Operational disturbance observed in Viedoc Reports on the European instance (v4.viedoc.net). Investigations are ongoing.
Posted Mar 03, 2025 - 15:10 UTC
This incident affected: Viedoc 4 - Europe (Main portal (clinic/admin/designer), Subject portal (ViedocMe), Application programming interface (API), Background processes (import/export/revisions/alerts/archive/disposal), Reporting tool (ViedocReports), Document management (ViedocTMF)).