Viedoc Me Submissions Recorded in UTC Instead of Local Time Zone

Incident Report for Viedoc

Resolved

The incident has been resolved with the release of hotfix 4.95.2 to all training and production instances.

This release prevents the issue from recurring going forward. However, Event dates already recorded in UTC will remain unchanged for now, and any out-of-window queries already triggered by this issue will also remain until corrected. Submissions currently stored in UTC will be corrected at a later date. The timing for this correction has not yet been confirmed.
Posted Jul 16, 2026 - 09:42 UTC

Update

We will begin releasing the hotfix to production environments during the day today. An update will be posted once the release is complete on all instances.
Posted Jul 16, 2026 - 06:53 UTC

Update

We are actively working to resolve this issue as quickly as possible. A hotfix is currently being finalized and tested, and we estimate it will be released to production in the first half of next week.
Posted Jul 14, 2026 - 14:57 UTC

Identified

Since the 4.95 release, Viedoc Me submissions have been recorded in the database using UTC time rather than the site's local time zone. If the UTC date and the site's local date differ at the time of submission, the Event date in Viedoc Clinic will incorrectly reflect the UTC date instead of the local date. Depending on the data entry windows defined in the study design, this may also result in out-of-window queries. The audit trail in the Viedoc Clinic UI, accessed via "Show History," displays the correct date and time stamp according to the local time zone.

This issue affects both the current and legacy versions of the Viedoc Me application.

The issue has been identified, and a fix is currently being prepared. The fix will ensure new submissions are stored using the site's local time zone, but it will not correct timestamps or out-of-window queries that have already occurred. These will be addressed in a future update.
Posted Jul 09, 2026 - 21:40 UTC
This incident affected: Viedoc 4 - Europe (Subject portal (ViedocMe)), Viedoc 4 - Japan (Subject portal (ViedocMe)), Viedoc 4 - China (Subject portal (ViedocMe)), and Viedoc 4 - US (Subject portal (ViedocMe)).